DATAtourisme

Problème pour dézipper un flux

Bonjour
Je parviens bien à télécharger le flux, via un CURL en php.
En revanche, lorsque je tente de le dézipper, j’obtiens l’erreur suivante :
End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.
unzip: cannot find zipfile directory in one of flux.zip or
flux.zip.zip, and cannot find flux.zip.ZIP, period.

Idem avec un tar.

Auriez-vous une piste pour solutionner le souci ?
Merci
Alexandre

Bonjour,

Note: Je suis utilisateur comme vous.

Je viens de télécharger un fichier zip d’un flux créé par:
https://diffuseur.datatourisme.gouv.fr/fr/flux
avec un url du type:
https://diffuseur.datatourisme.gouv.fr/webservice/{flux_id}/{app_key}

et il a été dézippé sans problème.

Est-ce que le format du flux « zip » a bien été spécifié lors de la création du flux dans le drop-down « Format » dans la page de création de flux? Avez-vous essayé de télécharger le fichier manuellement par le bouton " Télécharger la dernière version" et de le dézipper?

Il faut aussi noter que les fichiers sont automatiquement GZippés par le(s) serveur(s) Datatourisme. A voir dans votre programme PHP.

Bon courage.

Fred

Merci pour votre réponse.

En fait, je telecharge le fichier en PHP via CURL et lors du unzip en ligne de commande, ça me renvoie l’erreur indiqué.

En revanche, en téléchargement classique cela fonctionne bien.
J’imagine que j’ai un problème lors du download.

Alexandre

Il y a bien l’option --compressed ? (Flux gzip)

Du coup curl avec PHP c’est avec CURLOPT_ENCODING => ```
curl_setopt($ch,CURLOPT_ENCODING , « gzip »);

Merci !!
J’étais en train de regarder la sorite avec CURLOPT_VERBOSE et j’ai vu le content type à gzip sans savoir qu’en faire.

Donc je viens d’essayer avec CURLOPT_ENCODING, tout fonctionne nickel.
Un grand merci.

super ! n’hésite pas à noter que la réponse t’as été utile (case à cocher « solution »)

Pour info cette problématique a déjà été demandée sur le forum, n’hésite pas à utiliser la recherche pour voir avant de faire doublon :wink: