DATAtourisme

Problem in SparqlResolver.php on line 24

i want to execute this code

         <?php
         require __DIR__ . '/vendor/autoload.php';

 // instanciation du client
 $api = \Datatourisme\Api\DatatourismeApi::create('http://localhost:9999/blazegraph/namespace/kb/sparql');
// éxecution d'une requête
$rdftype="https://www.datatourisme.gouv.fr/ontology/core#Hotel";
$var='
 {
 poi (
  filters: [
  { hasType:  {_eq:"'.$rdftype.'"}} 

  ]

  size:4
 )
{  
    
  results {                 
  rdfs_label

  hasDescription {
    shortDescription    
  }
  isLocatedAt {
    schema_geo {
      schema_latitude   # <- Latitude du POI
      schema_longitude  # <- Longitude du POI
    }
  }
  
  
 }

 }
}';
 echo $var;

  $result = $api->process($var);
  // prévisualisation des résultats

highlight_string("<?php\n\$result =\n" . var_export($result, true) . ";\n?>");
?>

and i get this error
Fatal error: Declaration of Datatourisme\Api\Resolver\SparqlResolver\SparqlResolver::resolve() must be compatible with Datatourisme\Api\Resolver\ResolverInterface::resolve(Datatourisme\Api\Resolver\strin g $entryPoint, $arguments, Youshido\GraphQL\Execution\ResolveInfo $info) in C:\xampp\htdocs\myweb_for_ontolo\vendor\datatourisme\api\src\Resolver\SparqlResolver\SparqlResolver.php on line 24

Bonjour,

Conjecto répondra largement mieux que moi.
A l’aveugle je ne vois rien dans le code actuel qui provoque ça. Est ce que ton code est bien à jour ?

hello Simon
i think yes

Sorry I wrote in French. I Hope conjecto will find the answer !

merci Simon
c’est bon i find a solution :slight_smile: