DATAtourisme

Docker api : OutOfMemory

Bonjour,

J’ai commencé à prendre en main l’api en utilisant votre conteneur docker. ça fonctionnait bien quand j’essayais de chercher dans des données petites (tout les itinéraires cyclables par exemple).

Là je viens de télécharger le flux contentant TOUT les points d’interêts de votre plateforme et ça ne marche plus :frowning:

J’ai ça comme erreur (que j’arrive pas à avoir à chaque fois)

blazegraph_1 | ERROR: Banner.java:160: Uncaught exception in thread
blazegraph_1 | java.lang.OutOfMemoryError: Java heap space

Est-ce que vous pouvez me dire comment configurer pour que ça fonctionne avec tous les points d’interêts ?

Merci

Bonjour,

Si vous utilisez le docker-stack disponible ici -> https://framagit.org/datatourisme/docker-stack
Dans le fichier docker-compose.yml, il faut utiliser le paramètre : JAVA_OPTS: "-Xms512m -Xmx1g" à modifier en JAVA_OPTS: "-Xms2g -Xmx3g" dans votre contexte.

Message édité pour ne pas laisser d’information erronée.
Vous pouvez changer les valeurs du Java heap size (JAVA_XMS et JAVA_XMX dans le fichier docker-compose.yml).

Pour charger la base complète 3g en Xmx devrait suffire, il faut en outre 6Go de mémoire sur la machine qui fait tourner les dockers. (Sous linux il n’y a rien à configurer mais sous windows il faut configurer la mémoire allouée aux containers dans le menu Settings/Resources)

Cordialement.

Merci pour les informations.

J’ai modifié JAVA_XMS par 3g et JAVA_XMX par 6g dans le fichier docker-compose.yml ).

Je suis sur Mac, j’ai configuré dans Docker Desktop aussi

Quand je fais docker-compose up, j’ai l’impression que blazegraph n’arrive pas à charger les données :

blazegraph_1 | Reading properties: /docker-entrypoint-initdb.d/kb/RWStore.properties
blazegraph_1 | Will load from: /docker-entrypoint-initdb.d/kb/data
blazegraph_1 | Journal file: /var/lib/blazegraph/blazegraph.jnl

Il reste bloqué là.

Bonjour,

Nous venons de mettre à jour le repos https://framagit.org/datatourisme/docker-stack .
Lors de la dernière mise à jour du container Blazegraph sur dockerHub, les paramètres permettant de contrôler la mémoire ont changés.
Dans le fichier docker-compose.yml, il ne faut plus utiliser ceux que je vous avait spécifié, mais celui ci : JAVA_OPTS: "-Xms512m -Xmx1g" à modifier en JAVA_OPTS: "-Xms2g -Xmx3g" dans votre contexte.

Désolé pour l’information erronée, avec le bon paramètre cela devrait mieux marcher.

Cordialement.